Resolvendo Problemas na Instalação do Packet Tracer 7.1

Em meu notebook (Debian 9), utilizava a versão 7.0 do Packet Tracer e com o lançamento da versão 7.1, encontrei alguns problemas na sua instalação. Seguindo o processo padrão de instalação tudo correu bem, entretanto, ele não aparecia na lista de programas e também não respondia pelo terminal.

A solução encontrada para instalação da versão 7.1,  foi a adicionar bibliotecas que estavam faltando, alterar dois arquivos de configuração e editar o conteúdo do atalho.

Instalando bibliotecas

Depois de instalado, execute o comando ldd para listar quais bibliotecas estão faltando.

#ldd /opt/pt/bin/PacketTracer7

A saída do comando retorna as bibliotecas que estão faltando com a tag not found.

linux-vdso.so.1 (0x00007ffd427b0000)
 libcrypto.so.1.0.0 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007f8ed0473000)
libQt5WebKit.so.5 => not found

Faça a instalação das bibliotecas que estão faltando, depois execute novamente o comando ldd, para certificar que está tudo instalado.

Alterando os arquivos tpl

Agora, deve ser alterada a linha PTDIR=III nos seguintes arquivos: tpl.linguisttpl.packettracer. Ambos arquivos ficam localizados em /opt/pt.

Linha PTDIR=III alterar para PTDIR=/opt/pt.

 

Alterado o atalho

No momento da instalação é criado um atalho, mas não aparece na lista dos programas, pelo menos no Gnome. Para que o atalho se torne efetivo é necessário alterar seu conteúdo.

Acesse o atalho:

gedit /usr/share/applications/pt7.desktop

Adicione os seguinte conteúdo:

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Exec=/opt/pt/bin/PacketTracer7
Name=Cisco Packet Tracer
Icon=/opt/pt/art/app.png
Categories=GNOME;GTK;Utility;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Component=general

Feito! Agora basta clicar no ícone para abrir o Packet Tracer 7.1.

Captura de tela de 2017-09-19 14-09-39

Captura de tela de 2017-09-19 14-15-44

 

 

 

 

 

 

30 comentários

  1. Olá, eu estou com esse problema no meu Ubuntu 16.04 e tentei de tudo que achei na internet, mas da forma que você fez foi a que mais chegou perto de funcionar aqui, ao tentar abrir o programa pelo icone ele fica piscando como se fosse abrir e fecha, tem alguma ideia do que possa ser, todas as bibliotecas estão lá, seu script funcionou também até aparece na pesquisa.

    Curtir

    • Olá Rodrigo, não sei o que pode estar ocorrendo, mas tenta dar um #apt update e depois um #apt upgrade. E confira o script do atalho.

      Mas penso que talvez seja algo relacionado a permissão. Tente dar um chmod +x no atalho. # chmod +x /usr/share/applications/pt7.desktop.

      E os arquivos tpl foram alterados?

      Curtir

    • Olá João Pedro!
      Você pode alterar utilizando o terminal logando como root.

      Logando como root no Debian:
      $su

      Depois basta editar com um editor de texto de sua preferência. Eu utilizo o Nano.
      #nano /opt/pt/tpl.linguist

      Depois de alterar no Nano: Ctrl + O para salvar e Ctrl + x para sair.

      Feito!

      Curtir

  2. ola “VLANBR” (Peter) estou com problema ao instalar o lamp, da problema na instalação com o ubuntu, será que tenho que desinstalar o mysql e começar do 0? Ah e mais uma coisa acho que a gente faz faculdade juntos hehehehe , esse é feraa galera podem confiar, salve Tecnologia em Redes de Computadores.

    Curtir

  3. Peter, fiz todos os procedimentos para atualizar bibliotecas, permissões e mesmo assim continua a piscar somente através do atalho! Usando comando packettracer no terminal nem abre, o que pode ser? Utilizo o Ubuntu 16.04 e fiz o downgrade do 17.10, pois pensei eu que fosse em decorrência da Versão do Ubuntu

    Curtir

    • Bom dia Júlio! Provavelmente já tenha feito isso, mas o Rodrigo(comentário abaixo), estava com o mesmo problema… e resolveu apenas reiniciando o computador. E quanto aos arquivos “tpl”… alterou?

      Curtir

      • Peter, ao iniciar o aplicativo pelo terminal agora está apresentando esta mensagem:

        Starting Packet Tracer 7.1
        /usr/local/bin/packettracer: linha 8: 9779 Exceção de ponto flutuante (imagem do núcleo gravada) ./PacketTracer7 “$@” > /dev/null 2>&1

        Curtir

  4. Bom dia Pessoal, Peter seguir o tutorial e conseguir abrir packtracer pelo icone nos programas, meu problema agora a tela packettracer so abrir pela metade, e naõ consigo clicar nos botões, eu acho que seja referente a configuração do utulitarios da interface grafica eu uso distro Manjaro com KDE-PLASMA5 e não gnome, eu teria que substituir no arquivo essas linhas: Categories=GNOME;GTK;Utility; X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Component=general ? obrigado

    Curtir

      • Pelo terminal ele não abrir, ele starta e não abrir, pelo atalho gerado ele abrir porem com a tela pela metade e travado, mesmo iniciando como root, dei permissão de execução chmod +x no atalho e não resolveu as bibliotecas todas ok, apareceu tela de login netacademy fiz login normal, trava quando abrir na tela dos dispositivos

        Curtir

  5. remove a versão 7.1 e instalei a versão 7.0 funcionou bem sem nenhum problema e de cara após instalação, sem precisa fazer qualquer configuração alternativa, obrigado!

    Curtir

  6. Boa noite.
    Uso o Fedora 27 e quando eu executo o comando LDD ele informa que o pacote libcrypto.so.1.0.0 nao foi encontrado….a questão que eu ja rodei pra caramba e nada de achar…pede pra instalar o TOR, Steam e o Spotify que vai resolver e não funciona…fui no pbone e também não achei por la….gostaria de um help se possue este pacote e possa me fornecer…

    Obrigado

    Curtir

  7. Boa noite amigo, pode parecer ignorância, mas como instalar as bibliotecas que estão faltando.
    Pois no tutorial você diz para instalarmos mas não diz como.

    Obrigado pela ajuda.

    Curtir

  8. não consegui, aparece isso no terminal

    # /opt/pt/bin/PacketTracer7

    /opt/pt/bin/PacketTracer7: error while loading shared libraries: libQt5ScriptTools.so.5: cannot open shared object file: No such file or directory

    uso ubuntu 17

    Curtir

  9. Consegui o/ a solução foi essa:

    No terminal você pode localizar através do comando:
    # apt search libqt5webkit
    Ele vai listar os pacotes disponíveis para instalação.
    Provavelmente vai aparecer “libqt5webkit5”.
    Daí você pode instalar como o comando:
    # apt install libqt5webkit5

    Com o outro pacote pode fazer o mesmo:
    # apt search libQt5ScriptTools
    # apt install libqt5scripttools5

    agradeço ao Frank_Supremo do vivaolinux… vlw flws

    Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s